IronTree SecureIT (Backup and Protect) Incident
Incident Report for IronTree
Resolved
We have been informed of Maintenance by our service provider that is affecting this component, services will resume in the next 3 hours
Posted Jun 14, 2022 - 22:28 CAT
Investigating
We have picked up an issue on our IronTree SecureIT platform, we are engaging with our service providers on this issue and will have an update shortly.
Posted Jun 14, 2022 - 22:22 CAT
This incident affected: Backup and Protect (IronTree SecureIT Web Console (New Backup & Protect Web Console)).