IronTree RecoverIT (Backup & Protect) - Web Console Outage
Incident Report for IronTree
Resolved
The incident has been resolved
Posted Sep 20, 2024 - 08:57 CAT
Monitoring
A fix has been implemented and we are monitoring the system
Posted Sep 20, 2024 - 07:51 CAT
Investigating
We are currently investigating a web console outage affecting our Disaster Recovery Console
Posted Sep 20, 2024 - 06:57 CAT
This incident affected: IronTree RecoverIT (Disaster Recovery).